DX Suite Agent Appではエラー発生時、画面上部にエラーメッセージが表示されます。本記事ではエラー発生時に対応する方法を掲載します。
〇個のフォルダに問題があります。
画面表示の例
原因
AgentAppがアクセスできないフォルダがあります。
対応方法
- メッセージに問題のあるフォルダが表示されます。
- フォルダが削除されてしまっていないか、フォルダパスに問題ないかを確認ください。
複数のユーザにてご利用の場合、以下の点にご留意ください。
AIエージェントによるアクセス許可は、組織単位で管理されています。
複数の端末にローカルアプリをインストールし、それぞれの端末で特定のフォルダへのアクセスを許可している場合、ある端末に存在しないフォルダがあると、その端末上のアプリではエラーが表示されることがあります。
エラーが表示されていても、その端末で設定した連携に問題がなければ自動的に処理が行われますので、ご安心ください。
APIキーエラー
APIキーが無効か、必要な権限がありません。設定を確認してください。
画面表示の例
原因
AgentAppに設定しているAPIキーでDX Suiteにアクセスできません。
対応方法
- 設定されているAPIキーが削除されていないか、ご確認ください。
- 設定されているAPIキーが間違っていないか、ご確認ください。
ネットワークに接続できません。監視を停止しています。
接続が復旧すると自動で再開します。
画面表示の例
原因
ネットワークに接続できず、DX Suiteにアクセスできていません。
対応方法
-
ネットワークに正しく接続できているか、ご確認ください。
接続エラー
サーバーとの通信でエラーが発生しました。
画面表示の例
原因
通信途中でエラーが発生しています。様々な原因があり、発生したエラーメッセージが表示されます。
対応方法
- ネットワークと正しく接続できているかご確認ください。
-
プロキシ経由でアクセスされている場合は、通信が遮断されている可能性が考えられます。現時点では DX Suite Agent App 単体でプロキシ設定を行う機能は備えておりません。下記の通信を許可いただき、事象が解消するかご確認ください。ーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーホスト名:[ご利用のサブドメイン].dx-suite.comポート:443(HTTPS)ーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーー※可能であればワイルドカード指定(例:`*.dx-suite.com` ポート 443)の許可設定をご検討ください実際の設定適用や運用方法、影響範囲などにつきましては、貴社のご判断のもと、社内のシステム管理者様にてご確認・ご対応くださいますようお願いいたします。
SSL証明書エラー
画面表示の例
原因
お客様環境の証明書ストアに必要な、ルート CA証明書がインストールされていません。
対応方法
-
CA証明書を取得して「信頼されたルート証明機関」に追加していただく必要があります。「信頼されたルート証明機関」については、以下サイトの記事をご参照いただけますと幸いです。
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社内ネットワークで、SSLインスペクション等のHTTPS通信の復号・検査が行われている場合、本メッセージが表示されることがあります。「
*.dx-suite.com」宛の通信を HTTPS 検査(SSL インスペクション)の対象外(除外)とすることで、解決する場合があります。
解決しない場合
上記対応でも解決しない場合は、お問い合わせフォームからご連絡ください。
お問い合わせの際は下記情報を添えてください。
・エラーメッセージ(スクリーンショット)
・試した対処方法